2017.1及以后版本的WebStorm中,有时候搭建NodeJS服务器的时候,会出现require,module这些关键词出现unresolved function or method错误,很影响美观。以下是解决办法:


  1. 打开WebStrom的Preference菜单,在search里面搜索nodejs。
  2. 选中Language & Frameworks中的Node.js & Frameworks
  3. 看到右边有一行:Node.js Core library is disabled,点击enable按钮即可。

完成后Preference界面如下图所示:
01.jpg

完成!